您的位置:首页 > 其它

hdu 1358 Period(kmp)

2015-08-11 10:51 387 查看
Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is
one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on
it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing
order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0


Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4


//从字符串的第二个开始,看前面是循环串吗,是的话就输出此时的位置,和循环串的周期,周期必须大于1

#include <iostream>

#include <stdio.h>

#include <string.h>

#include <queue>

using namespace
std;

int Next[1000100];

char str[1000100];

void GetNext(char *s,int len)

{

Next[0]=-1;

int j=-1;

int i=0;

while (i<len)

{

if(j==-1 || s[i]==s[j])

{

i++;

j++;

// if(s[i]==s[j])

// Next[i]=Next[j];

// else

Next[i]=j;

}

else

j=Next[j];

}

}

int main()

{

int t,len,cnt=1;

while(scanf("%d",&t) && t)

{

scanf("%s",str);

len=strlen(str);

GetNext(str,len);

printf("Test case #%d\n",cnt++);

for (int i=2; i<=len; i++)

{

int k=i-Next[i];

if(i%k==0 && i/k>1) //至少要循环两次

printf("%d %d\n",i,i/k);

}

printf("\n");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: