您的位置:首页 > 其它

HDU 4920 Matrix multiplication

2015-08-11 10:33 357 查看

Matrix multiplication

Time Limit: 2000ms
Memory Limit: 131072KB
This problem will be judged on HDU. Original ID: 4920
64-bit integer IO format: %I64d Java class name: Main

Given two matrices A and B of size n×n, find the product of them.

bobo hates big integers. So you are only asked to find the result modulo 3.

Input

The input consists of several tests. For each tests:

The first line contains n (1≤n≤800). Each of the following n lines contain n integers -- the description of the matrix A. The j-th integer in the i-th line equals Aij. The next n lines describe the matrix B in similar format (0≤Aij,Bij≤109).

Output

For each tests:

Print n lines. Each of them contain n integers -- the matrix A×B in similar format.

Sample Input

1
0
1
2
0 1
2 3
4 5
6 7

Sample Output

0
0 1
2 1


Source

2014 Multi-University Training Contest 5

解题:利用cache进行加速。。

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int maxn = 810;
int a[maxn][maxn],b[maxn][maxn],c[maxn][maxn];
int main() {
int n;
while(~scanf("%d",&n)) {
memset(c,0,sizeof c);
for(int i = 0; i < n; ++i)
for(int j = 0; j < n; ++j) {
scanf("%d",a[i]+j);
a[i][j] %= 3;
}
for(int i = 0; i < n; ++i)
for(int j = 0; j < n; ++j) {
scanf("%d",b[i]+j);
b[i][j] %= 3;
}
for(int i = 0; i < n; ++i)
for(int k = 0; k < n; ++k)
for(int j = 0; j < n; ++j)
c[i][j] += a[i][k]*b[k][j];
for(int i = 0; i < n; ++i) {
for(int j = 0; j + 1 < n; ++j)
printf("%d ",c[i][j]%3);
printf("%d\n",c[i][n-1]%3);
}
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: