您的位置:首页 > 其它

poj 3349 Snowflake Snow Snowflakes

2015-08-10 21:17 519 查看
题意:一共n组数,每组有六个数,查询在n组数列里有没有(包含的数字相同,并且数字顺序符合,可以是顺序也可以是逆序,也可以是从任意一个数开始的顺序)

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake
has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed byn lines, each describing a snowflake. Each snowflake will be described by a line containing six
integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms.
For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.

If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output
Twin snowflakes found.

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#define LL long long
#define INF 0x3f3f3f3f
#define Mod 100007
//#pragma comment(linker,"STACK:1024000,1024000")
using namespace std;

struct node
{
int a[6];
node *next;
}*p,*q;

struct Point
{
int num;
node *next;
} Head[Mod];

bool cmp(node *a,node *b)
{
for(int i=0; i<6; i++)
if((a->a[0] == b->a[i] && a->a[1] == b->a[(i+1)%6] && a->a[2] == b->a[(i+2)%6] && a->a[3] == b->a[(i+3)%6] && a->a[4] == b->a[(i+4)%6] && a->a[5] == b->a[(i+5)%6]) || (a->a[0] == b->a[i] && a->a[1] == b->a[(i+5)%6] && a->a[2] == b->a[(i+4)%6] && a->a[3] == b->a[(i+3)%6] && a->a[4] == b->a[(i+2)%6] && a->a[5] == b->a[(i+1)%6]) )
return true;
return false;
}

int main()
{
//freopen("in.txt","r",stdin);
int n;
while(~scanf("%d",&n))
{
for(int i=0; i<Mod; i++)
{
Head[i].num = 0;
Head[i].next = NULL;
}
for(int i=0; i<n; i++)
{
p = new node;
p->next = NULL;
int sum = 0;
for(int j=0; j<6; j++)
{
scanf("%d",&p->a[j]);
sum = (sum + p->a[j])%Mod;
}
Head[sum].num ++;
p->next = Head[sum].next;
Head[sum].next = p;
}
bool flag = false;
for(int i=0; i<Mod; i++)
{
if(Head[i].num <= 1)
continue;
p = Head[i].next;
while(p)
{
q = p->next;
while(q)
{
if(cmp(q,p))
{
flag = true;
break;
}
if(flag)
break;
q = q->next;
}
if(flag)
break;
p = p->next;
}
}

if(flag)
printf("Twin snowflakes found.\n");
else
printf("No two snowflakes are alike.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: