您的位置:首页 > 产品设计 > UI/UE

杭电 1711 Number Sequence kmp

2015-08-10 19:48 309 查看

Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15185 Accepted Submission(s): 6666



Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.





Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].





Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.





Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1






Sample Output
6
-1



还是对kmp算法理解的不是太透彻,虽说基本上都能够理解了吧。

一直无法输出正确的数,最后看了别人的代码,发现别人都是直接让循环跳出的,这样不仅省时而且还正确。



#include<stdio.h>
#include<string.h>
#define maxn 1000000+10
int str[maxn],buf[maxn],n,m,next[maxn],ans;

void getnext(){
	int i = 0,j = -1;
	next[i] = j;
	while(i < m){
		if(j == -1 || str[i] == str[j]){
			++i;++j;
			next[i] = j;
		}
		else j = next[j];
	}
}

void kmp(){
	int i = 0, j = 0;
	getnext();
	while(j != m&&i < n){
		if(j == -1 || buf[i] == str[j]){
			++i;++j;
		}
		else j = next[j];
	}
	if(j == m){
				ans = i - m + 1;
			}
	else ans = -1;
}

int main(){
	int t,i;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&m);
		for(i = 0;i < n;i++){
			scanf("%d",&buf[i]);
		}
		for(i = 0;i < m;i++){
			scanf("%d",&str[i]);
		}
		kmp();
		printf("%d\n",ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: