您的位置:首页 > 其它

hdoj-1016-Prime Ring Problem【深搜】

2015-08-10 18:39 423 查看

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 34347 Accepted Submission(s): 15188



[align=left]Problem Description[/align]
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



[align=left]Input[/align]
n (0 < n < 20).

[align=left]Output[/align]
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

[align=left]Sample Input[/align]

6
8


[align=left]Sample Output[/align]

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2


[align=left]Source[/align]
Asia 1996, Shanghai (Mainland China)

[align=left]Recommend[/align]
JGShining | We have carefully selected several similar problems for you:10101312

1072
1242
1175

<pre name="code" class="html">#include<stdio.h>
#include<string.h>
bool prim[44],visit[22];
int b[22];
int n;
void f(){
prim[2]=prim[3]=prim[5]=prim[7]=prim[11]=prim[13]=prim[17]=prim[19]=1;
prim[23]=prim[29]=prim[31]=prim[37]=prim[41]=1;
}
void dfs(int op){
if(op==n){
if(!prim[b[op-1]+b[0]])	return;
printf("%d",b[0]);
for(int i=1;i<n;++i)
printf(" %d",b[i]);
printf("\n");
return;
}
for(int i=2;i<=n;++i){
if(!visit[i]){
if(prim[b[op-1]+i]){
b[op]=i;visit[i]=1;dfs(op+1);
}
visit[i]=0;
}
}
}
int main(){
f();
int ncas=0;
while(~scanf("%d",&n)){
printf("Case %d:\n",++ncas);
memset(visit,0,sizeof(visit));
b[0]=1;dfs(1);
printf("\n");
}
return 0;
}




                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: