您的位置:首页 > 其它

HDOJ 1686 Oulipo(KMP)

2015-08-10 17:37 274 查看

Oulipo

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7429 Accepted Submission(s): 2990



Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.


Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.


Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.


Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
***ERDXIVYERDIAN



Sample Output
1
3
0



一直看到kmp的题就跳过,直接导致周赛跪了,两道kmp模板题都不会。QAQ,补救一下。不能理解也要记住模板。

这题是kmp的模板题,求短字符串在长字符串中出现的次数,代码如下:

<span style="font-size:12px;">#include<cstdio>
#include<cstring>
#define maxn 1000010
char str[10010],s[maxn];
int next[10010],lena,lenb,ans;

void getnext()
{
	int i=0,j=-1;
	next[0]=-1;
	while(i<lena)
	{
		if(j==-1||str[i]==str[j])
		   next[++i]=++j;
		else
		   j=next[j];
	}
}

void kmp()
{
	int i=0,j=0;
	while(i<lenb)
	{
		if(j==-1||s[i]==str[j])
		{
			i++;
			j++;
			if(j==lena)
			  ans++;
		}
		else
		   j=next[j];
	}
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s%s",str,s);
		ans=0;
		lena=strlen(str);
		lenb=strlen(s);
		getnext();
		kmp();
		printf("%d\n",ans);
	}
	return 0;
}</span>



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: