您的位置:首页 > 其它

Let the Balloon Rise

2015-08-10 17:28 197 查看
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 90162 Accepted Submission(s): 34230

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

0

Sample Output

red

pink

水水水。。。

#include<string.h>
#include<stdio.h>
#include<algorithm>
#define max 1010
using namespace std;
struct stu
{
    char s[max];
    int w;
}a[max];
int cmp(stu c,stu b)
{
    return c.w>b.w;
}
int main()
{
    int n,i,j;
    while(scanf("%d",&n),n)
    {
        for(int i=0;i<n;i++)
        {
            getchar();
            scanf("%s",&a[i].s);
            a[i].w=1;//初始化赋值为一,它本身就算是有一个
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<i;j++)
            {
                if(strcmp(a[i].s,a[j].s)==0)
                a[i].w++;//不可写作a[i].w+=a[j].w;经过循环,a[i].w的值早已不为一
            }
        }
        sort(a,a+n,cmp);
        printf("%s\n",a[0].s);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: