您的位置:首页 > 其它

hdu 5365 Run 枚举

2015-08-10 15:52 281 查看

Run

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 839 Accepted Submission(s): 361



Problem Description

AFA is a girl who like runing.Today,he download an app about runing .The app can record the trace of her runing.AFA will start runing in the park.There are many chairs in the park,and AFA will start his runing in a chair and end in this chair.Between two chairs,she
running in a line.she want the the trace can be a regular triangle or a square or a regular pentagon or a regular hexagon.

Please tell her how many ways can her find.

Two ways are same if the set of chair that they contains are same.


Input

There are multiply case.

In each case,there is a integer n(1 < = n < = 20)in a line.

In next n lines,there are two integers xi,yi(0 < = xi,yi < 9) in each line.


Output

Output the number of ways.


Sample Input

4
0 0
0 1
1 0
1 1




Sample Output

1




Source

BestCoder Round #50 (div.2)

只有四边形的才是答案。枚举四个点。有6条边,4边相等,剩下两条边也相等,且长度是sqrt(2)*短边即可

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<cstdio>
using namespace std;
struct Point{
    int x,y;
    Point(int _x=0,int _y=0):x(_x),y(_y){}
};
Point operator - (Point a,Point b){
    return Point(a.x-b.x,a.y-b.y);
}
int len(Point a){
    return a.x*a.x+a.y*a.y;
}

Point p[21];
vector<Point> po;
int ans;
int n;
vector<int> e;
void dfs(int q,int num){
    if(num == 4){
        e.clear();
        for(int i = 0;i < 4; i++){
            for(int j = i+1;j < 4;j ++){
                e.push_back(len(po[i]-po[j]));
            }
        }
        sort(e.begin(),e.end());
        if(e[0] == e[1] && e[1] == e[2] && e[2] == e[3] && e[4] == 2*e[1] && e[5] == 2*e[1])
            ans += 1;
        return ;
    }
    for(int i = q;i < n; i++){
        po.push_back(p[i]);
        dfs(i+1,num+1);
        po.pop_back();
    }
}
int main(){
    while(scanf("%d",&n)!=EOF){
        for(int i = 0;i < n; i++)
            scanf("%d%d",&p[i].x,&p[i].y);
        ans = 0;
        dfs(0,0);
        int res = 0;
        printf("%d\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: