您的位置:首页 > 其它

HDU 1160

2015-08-10 14:59 399 查看
FatMouse’s Speed

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11814 Accepted Submission(s): 5188

Special Judge

Problem Description

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m
then it must be the case that

W[m[1]] < W[m[2]] < … < W[m
]

and

S[m[1]] > S[m[2]] > … > S[m
]

In order for the answer to be correct, n should be as large as possible.

All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input

6008 1300

6000 2100

500 2000

1000 4000

1100 3000

6000 2000

8000 1400

6000 1200

2000 1900

Sample Output

4

4

5

9

7

FatMouse’s Speed

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11814 Accepted Submission(s): 5188

Special Judge

Problem Description

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m
then it must be the case that

W[m[1]] < W[m[2]] < … < W[m
]

and

S[m[1]] > S[m[2]] > … > S[m
]

In order for the answer to be correct, n should be as large as possible.

All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input

6008 1300

6000 2100

500 2000

1000 4000

1100 3000

6000 2000

8000 1400

6000 1200

2000 1900

Sample Output

4

4

5

9

7

最大递增子序列的问题,还得输出路径。注意,有多条路径时随意输出一条即可。所以和样例输出不同能照样AC(我输出的就是4 4 5 9 8不是4 4 5 9 7)

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <stack>
//#define LOCAL
using namespace std;

typedef struct{
int sign;
int weight;
int speed;
}Point;

Point a[1010];
int dp[1010];
int pre[1010];
int Pre[1010];

bool cmp(Point a,Point b){
if(a.weight<b.weight)
return true;
if(a.weight == b.weight)
if(a.speed>b.speed)
return true;
return false;
}

int main()
{
#ifdef LOCAL
freopen("data.in","r",stdin);
freopen("data.out","w",stdout);
#endif // LOCAL
int i,j;
int n = 1;
while(scanf("%d%d",&(a
.weight),&(a
.speed))!=EOF){
a
.sign = n;
n++;
}

sort(a+1,a+n,cmp);
memset(dp,0,sizeof(0));
a[0].speed = 0x3f3f3f3f;
for(i = 1;i<n;i++){
int Max = 0;
for(j = i-1;j>=0;j--){
if(a[i].speed<a[j].speed&&a[i].weight>a[j].weight)
if(dp[Max]<dp[j])
Max = j;

}
dp[i] = dp[Max] + 1;
pre[i] = a[Max].sign;
}
int Max = 1;
for(i = 2;i<n;i++)
if(dp[Max]<dp[i])
Max = i;
printf("%d\n",dp[Max]);
for(i = 1;i<n;i++)
Pre[a[i].sign] = pre[i];
stack<int> Stack;
i = a[Max].sign;
Stack.push(i);
while(Pre[i]){
Stack.push(Pre[i]);
i = Pre[i];
}
while(!Stack.empty()){
printf("%d\n",Stack.top());
Stack.pop();
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划 杭电