您的位置:首页 > 其它

POJ 3259Wormholes

2015-08-10 14:33 183 查看
DescriptionWhile exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
InputLine 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires Tseconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.OutputLines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).Sample Input[code]2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample OutputNO
YES[/code]HintFor farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
题意:存在两种路,一种双向耗时,另一种单向能返回过去,用dist正负表示权值,BF不废话。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int N = 600;
int n, m, w;
int d[N];
struct Edge {
int from, to, dist;
};
vector<Edge> edges;

void addEdge(int from, int to, int dist) {
edges.push_back((Edge){from, to, dist});
}
void input() {
scanf("%d %d %d", &n, &m, &w);
int a, b, c;
for (int i = 0; i < m; i++) {
scanf("%d %d %d", &a, &b, &c);
addEdge(a, b, c);
addEdge(b, a, c);
}
for (int i = 0; i < w; i++) {
scanf("%d %d %d", &a, &b, &c);
addEdge(a, b, -c);
}
}

bool BF() {
memset(d, 0, sizeof(d));
int a, b;
for (int i = 0; i < n; i++) {
for (int j = 0; j < edges.size(); j++) {
a = edges[j].from, b = edges[j].to;
if (d[b] > d[a] + edges[j].dist) {
d[b] = d[a] + edges[j].dist;
if(i == n-1) return true;
}
}
}
return false;
}
int main() {
int T;
scanf("%d", &T);
while (T--) {
edges.clear();
input();
if ( BF() ) printf("YES\n");
else printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: