您的位置:首页 > 其它

Network

2015-08-10 13:50 351 查看
Network

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 7471Accepted: 2729
Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

Source

2008 Asia Hefei Regional Contest Online by USTC
network中有许多computer,之间或间接的连接,问有哪两个电脑之间的连接对整个network的连通性有影响,就是求桥,过程中加边,桥的值更新

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <queue>
#include <cmath>
#include <stack>
#include <cstring>

using namespace std;

#define INF 0xfffffff
#define min(a,b) (a<b?a:b)
#define N 100005

vector<vector<int> > G;

int n, m, ans, Time;
int low
, dfn
, f
, bridge
;

void init()
{
G.clear();
G.resize(n+1);
Time = ans = 0;
memset(low, 0, sizeof(low));
memset(dfn, 0, sizeof(dfn));
memset(f, 0, sizeof(f));
memset(bridge, 0, sizeof(bridge));
}

void Tarjan(int u, int fa)
{
f[u] = fa;
low[u] = dfn[u] = ++Time;
int len = G[u].size(), v, k = 0;

for(int i = 0; i < len; i++)
{
v = G[u][i];

if(v == fa && k == 0)    // 如果这个点和父节点一样说明统计过了,就不用管了,毕竟这是一个双向图
{
k++;
continue;
}
if(!low[v])
{
Tarjan(v, u);
low[u] = min(low[v], low[u]);
if(low[v] > dfn[u])
{
bridge[v]++;   // 如果是桥,标志,ans++
ans++;
}
}
else
low[u] = min(low[u], dfn[v]);
}
}

void Lca(int l, int r)
{
if(l == r)
return ;
if(dfn[l] > dfn[r])
{
if(bridge[l] == 1)
{
bridge[l] = 0;   // 随之更新
ans--;
}
Lca(f[l], r);
}
else
{
if(bridge[r] == 1)
{
bridge[r] = 0;
ans--;
}
Lca(l, f[r]);
}
}

int main()
{
int a, b, x, y, q, t = 1;

while(scanf("%d%d", &n, &m), n+m)
{
init();

printf("Case %d:\n", t);
t++;

while(m--)
{
scanf("%d%d", &a, &b);
G[a].push_back(b);
G[b].push_back(a);
}
Tarjan(1, 0);
scanf("%d", &q);

while(q--)
{
scanf("%d%d", &x, &y);
Lca(x, y);
printf("%d\n", ans);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: