您的位置:首页 > 其它

HDOJ 4190 Distributing Ballot Boxes(二分)

2015-08-10 11:42 411 查看

Distributing Ballot Boxes

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1132    Accepted Submission(s): 577


[align=left]Problem Description[/align]
Today, besides SWERC'11, another important event is taking place in Spain which rivals it in importance: General Elections. Every single resident of the country aged 18 or over is asked to vote in order to choose representatives for
the Congress of Deputies and the Senate. You do not need to worry that all judges will suddenly run away from their supervising duties, as voting is not compulsory.

The administration has a number of ballot boxes, those used in past elections. Unfortunately, the person in charge of the distribution of boxes among cities was dismissed a few months ago due to nancial restraints. As a consequence, the assignment of boxes
to cities and the lists of people that must vote in each of them is arguably not the best. Your task is to show how efficiently this task could have been done.

The only rule in the assignment of ballot boxes to cities is that every city must be assigned at least one box. Each person must vote in the box to which he/she has been previously assigned. Your goal is to obtain a distribution which minimizes the maximum
number of people assigned to vote in one box.

In the first case of the sample input, two boxes go to the fi rst city and the rest to the second, and exactly 100,000 people are assigned to vote in each of the (huge!) boxes in the most efficient distribution. In the second case, 1,2,2 and 1 ballot boxes
are assigned to the cities and 1,700 people from the third city will be called to vote in each of the two boxes of their village, making these boxes the most crowded of all in the optimal assignment.
 

[align=left]Input[/align]
The fi rst line of each test case contains the integers N (1<=N<=500,000), the number of cities, and B(N<=B<=2,000,000), the number of ballot boxes. Each of the following N lines contains an integer ai,(1<=ai<=5,000,000),
indicating the population of the ith city.

A single blank line will be included after each case. The last line of the input will contain -1 -1 and should not be processed.
 

[align=left]Output[/align]
For each case, your program should output a single integer, the maximum number of people assigned to one box in the most efficient assignment.
 

[align=left]Sample Input[/align]

2 7
200000
500000

4 6
120
2680
3400
200

-1 -1

 

[align=left]Sample Output[/align]

100000
1700

给出了n个城市和投票箱m,求一个投票箱最少要塞多少票

二分

ac代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#define MAXN 500000
#include<algorithm>
using namespace std;
int num[MAXN];
int main()
{
int n,m,i,M,mi,mid;
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==-1&&m==-1)
break;
M=0;
for(i=0;i<n;i++)
{
scanf("%d",&num[i]);
if(num[i]>M)
M=num[i];
}
int low=1;
int high=M;
while(low<high)
{
mid=(low+high)/2;
int sum=0;
int bz=0;
for(i=0;i<n;i++)
{
sum+=ceil(num[i]*1.0/mid);//向上取整
if(sum>m)
{
bz=1;
break;
}
}
if(bz)
low=mid+1;
else
high=mid;
}
printf("%d\n",high);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: