您的位置:首页 > 产品设计 > UI/UE

Common Subsequence

2015-08-10 10:32 477 查看
Common Subsequence

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 43153Accepted: 17485
Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input

abcfbc         abfcab
programming    contest
abcd           mnp

Sample Output

4
2
0

Source

Southeastern Europe 2003
这么明显的一道动态规划,学长还讲过,这么low的题。。是不是傻

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

#define N 500

int main()
{
char str1
, str2
;
int dp

;

while(~scanf("%s %s", str1, str2))
{
memset(dp, 0, sizeof(dp));

int len1 = strlen(str1), len2 = strlen(str2);

for(int i = 1; i <= len1; i++)
{
for(int j = 1; j <= len2; j++)
{
if(str1[i-1] == str2[j-1])
dp[i][j] = dp[i-1][j-1]+1;
else
dp[i][j] = max(dp[i][j-1], dp[i-1][j]);
}
}
printf("%d\n", dp[len1][len2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: