您的位置:首页 > 产品设计 > UI/UE

poj 1458 Common Subsequence【LCS】

2015-08-10 10:10 609 查看
Common Subsequence

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 43132Accepted: 17472
Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1,
i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find
the length of the maximum-length common subsequence of X and Y.
Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc         abfcab
programming    contest
abcd           mnp

Sample Output
4
2
0

Source

Southeastern Europe 2003

分析:求最长公共子序列的模板题。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#define max(a,b) (a>b?a:b)
using namespace std;
char s1[1010],s2[1010];
int dp[1010][1010];
int main()
{
while(scanf("%s%s",s1,s2)!=EOF)
{
memset(dp,0,sizeof(dp));
int l1,l2;
l1=strlen(s1);
l2=strlen(s2);
int i,j;
for(i=1;i<=l1;i++)
{
for(j=1;j<=l2;j++)
{
if(s1[i-1]==s2[j-1])
dp[i][j]=dp[i-1][j-1]+1;
else{
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
}
}
printf("%d\n",dp[l1][l2]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: