您的位置:首页 > 其它

hdu 1045 Fire Net (二分匹配)

2015-08-10 10:03 309 查看
http://acm.hdu.edu.cn/showproblem.php?pid=1045


Fire Net

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8000 Accepted Submission(s): 4575



Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least
one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses
in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.



Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The
next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.



Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.



Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0




Sample Output

5
1
5
2
4



一个阵地可以向四周扫射,求出来最多能修多少个阵地,墙不可以被扫射透,阵地不能同行或者或者列(有墙隔着例外)

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>

using namespace std;

#define N 305
#define INF 0xfffffff
#define PI acos (-1.0)
#define EPS 1e-8

struct node
{
    int x, y;
} stu

;

int n, x, y, used
, g

;
bool vis
;
char s

;

bool Find (int u);///匈牙利算法匹配

int main ()
{
    while (scanf ("%d", &n), n)
    {
        memset (used, 0, sizeof (used));
        memset (g, 0, sizeof (g));

        for (int i=0; i<n; i++)
            scanf ("%s", s[i]);

        x = y = 0;
        for (int i=0; i<n; i++)
            for (int j=0; j<n; j++)
            {
                ///把图分割,以相邻的"."为行和列重新分配编号
                if (s[i][j] == '.')
                {
                    if (j == 0 || s[i][j-1] == 'X')
                        x++;
                    stu[i][j].x = x;
                }
                if (s[j][i] == '.')
                {
                    if (j == 0 || s[j-1][i] == 'X')
                        y++;
                    stu[j][i].y = y;
                }
            }

        for (int i=0; i<n; i++)
            for (int j=0; j<n; j++)
                if (s[i][j] == '.')
                    g[ stu[i][j].x ][ stu[i][j].y ] = true;///列与行匹配

        int ans = 0;
        for (int i=1; i<=x; i++)
        {
            memset (vis, false, sizeof (vis));
            if (Find (i)) ans++;
        }
        printf ("%d\n", ans);
    }
    return 0;
}

bool Find (int u)
{
    for (int i=1; i<=y; i++)
    {
        if (!vis[i] && g[u][i])
        {
            vis[i] = true;
            if (!used[i] || Find ( used[i]) )
            {
                used[i] = u;
                return true;
            }
        }
    }
    return false;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: