您的位置:首页 > 其它

POJ_1470_ClosestCommonAncestors

2015-08-10 00:25 302 查看
Closest Common Ancestors

Time Limit: 2000MSMemory Limit: 10000K
Total Submissions: 17232Accepted: 5525
Description
Write a program that takes as input a rooted tree and a list of pairs of vertices. For each pair (u,v) the program determines the closest common ancestor of u and v in the tree. The closest common ancestor of two nodes u and v
is the node w that is an ancestor of both u and v and has the greatest depth in the tree. A node can be its own ancestor (for example in Figure 1 the ancestors of node 2 are 2 and 5)
Input
The data set, which is read from a the std input, starts with the tree description, in the form:

nr_of_vertices

vertex:(nr_of_successors) successor1 successor2 ... successorn

...

where vertices are represented as integers from 1 to n ( n <= 900 ). The tree description is followed by a list of pairs of vertices, in the form:

nr_of_pairs

(u v) (x y) ...

The input file contents several data sets (at least one).

Note that white-spaces (tabs, spaces and line breaks) can be used freely in the input.
Output
For each common ancestor the program prints the ancestor and the number of pair for which it is an ancestor. The results are printed on the standard output on separate lines, in to the ascending order of the vertices, in the format:
ancestor:times

For example, for the following tree:



Sample Input
5
5:(3) 1 4 2
1:(0)
4:(0)
2:(1) 3
3:(0)
6
(1 5) (1 4) (4 2)
(2 3)
(1 3) (4 3)

Sample Output
2:1
5:5

Hint
Huge input, scanf is recommended.
Source
Southeastern Europe 2000

这貌似是个著名问题

不过,目前不会正统方法

放在了树状数组和线段树的分类里,但是并不知道为什么

留下来个坑

自己就用了一种很菜的方法

反正询问是从下往上的,干脆让儿子节点找自己的父亲

这个感觉来自于并查集

另外输入输出这个题目有点坑

不过c语言可以利用自身的优势,强行查找空格等

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

const int M=905;
int tree[M];
int isp[M];
int num[M];

void sett()
{
for(int i=1;i<M;i++)
tree[i]=i;
}

int find(int a,int b)
{
memset(isp,0,sizeof(isp));
while(tree[a]!=a)
{
isp[a]=1;
a=tree[a];
}
isp[a]=1;
while(!isp[b])
b=tree[b];
return b;
}

int main()
{
int v;
int f,sn,s;
int qn,qa,qb;
//freopen("1.in","r",stdin);
//freopen("2.out","w",stdout);
while(scanf("%d",&v)!=EOF)
{
memset(num,0,sizeof(num));
sett();
for(int i=0;i<v;i++)
{
scanf("%d %*c%*c %d %*c",&f,&sn);
//cout<<"11 "<<f<<" "<<sn<<endl;
for(int j=0;j<sn;j++)
{
scanf("%d",&s);
tree[s]=f;            //生成从下往上的伪树,有点像并查集
}
}
//cout<<"1";
scanf("%d",&qn);
for(int i=0;i<qn;i++)
{
scanf(" %*c%d%d %*c",&qa,&qb);
//cout<<qa<<" "<<qb<<endl;
num[find(qa,qb)]++;
}
for(int i=1;i<=v;i++)
{
if(num[i])
printf("%d:%d\n",i,num[i]);
}
}
return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: