您的位置:首页 > 其它

poj 2586 Y2K Accounting Bug

2015-08-09 21:54 274 查看
Y2K Accounting Bug

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 11547Accepted: 5810
Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.

All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how
many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost
sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input
59 237
375 743
200000 849694
2500000 8000000


Sample Output
116
28
300612
Deficit


Source

Waterloo local 2000.01.29
#include <iostream>
using namespace std;

int main()
{
int s,d;
int res;
while(cin>>s && cin>>d)
{
if(d>4*s)res=10*s-2*d;
else if(2*d>3*s)res=8*s-4*d;
else if(3*d>2*s)res=6*(s-d);
else if(4*d>s)res=3*(s-3*d);
else res=-1;
if(res<0)cout<<"Deficit"<<endl;
else cout<<res<<endl;
}
return 0;
}

/*#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

int main()
{
int s,d;
while(cin>>s>>d)
{
int flag=1;
int num;
for(int i=1;i<=8;i++)
{
int sum=0;
for(int j=0;j<5;j++)
{
num=i+j;
if(num==5||num==10)
{
sum-=d;
}
else
{
sum+=s;
}
}
if(sum>=0)
{
flag=0;
break;
}
}
if(flag==1&&10*s-2*d>=0)
{
cout<<10*s-2*d<<endl;   //sum<0&&全年额度>=0才输出
continue;
}
else
for(int i=1;i<=8;i++)
{   flag=1;
int sum=0;
for(int j=0;j<5;j++)
{
num=i+j;
if(num==5||num==4||num==9||num==10)
{
sum-=d;
}
else
{
sum+=s;
}
}
if(sum>=0)
{
flag=0;
break;
}
}
if(flag==1&&8*s-4*d>=0)
{
cout<<8*s-4*d<<endl;
continue;
}
else
for(int i=1;i<=8;i++)
{    flag=1;
int sum=0;
for(int j=0;j<5;j++)
{
num=i+j;
if(num==5||num==4||num==3||num==8||num==9||num==10)
{
sum-=d;
}
else
{
sum+=s;
}
}
if(sum>=0)
{
flag=0;
break;
}
}
if(flag==1&&6*s-6*d>=0)
{
cout<<6*s-6*d<<endl;
continue;
}
else
for(int i=1;i<=8;i++)
{   flag=1;
int sum=0;
for(int j=0;j<5;j++)
{
num=i+j;
if(num==1||num==6||num==11)
{
sum+=s;
}
else
{
sum-=d;
}
}
if(sum>=0)
{
flag=0;
break;
}
}
if(flag==1&&3*s-9*d>=0)
{
{cout<<3*s-9*d<<endl;
continue;
}
}
else
cout<<"Deficit";
cout<<endl;
}
}

*/

/*有一个公司由于某个病毒使公司赢亏数据丢失,但该公司每月的 赢亏是一个定数,要么一个月赢利s,要么一月亏d。现在ACM只知道该公司每五个月有一个赢亏报表
,每次报表赢利情况都为亏。在一年中这样的报表总共有8次(1到5,2到6,…,8到12),现在要编一个程序确定当赢s和亏d给出,并满足每张报表为亏的情况下,
全年公司最高可赢利多少,若存在,则输出多多额,若不存在,输出"Deficit"。

分析:s为盈利月盈利额,d为亏损月额度
在保证连续5个月都亏损的前提下,使得每5个月中亏损的月数最少。根据d和s的不同五种情况
x=1:  ssssd,ssssd,ss    d>4s     赢利10个月    10s-2d
x=2:  sssdd,sssdd,ss    2d>3s    赢利8个月     8s-4d
x=3:  ssddd,ssddd,ss    3d>2s    赢利6个月     6s-6d
x=4:  sdddd,sdddd,sd    4d>s     赢利3个月     3s-9d
x=5:  ddddd,ddddd,dd    4d<s     无赢利
注意:0也算是盈利*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: