您的位置:首页 > 其它

poj2236 并查集

2015-08-09 13:18 281 查看
如题:http://poj.org/problem?id=2236

Wireless Network

Time Limit: 10000MSMemory Limit: 65536K
Total Submissions: 19456Accepted: 8173
Description
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The
computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded
as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next
N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following
two formats:

1. "O p" (1 <= p <= N), which means repairing computer p.

2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output
FAIL
SUCCESS

Source
POJ Monthly,HQM






思路 :使用in数组记录当前电脑是否在网络中,然后每次将在网络中的集合尝试合并,能连接就合并。



#include<iostream>

#include<cstdio>

#include<cstring>

#include<string>

#include<cmath>

using namespace std;

#define MAXN 1005

struct point

{

int x,y;

};

point a[MAXN];

int in[MAXN];

int f[MAXN];

double dis(point a,point b)

{

return sqrt((double)((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)));

}

int find(int x)

{

if(x==f[x])

return x;

return f[x]=find(f[x]);

}

void Union(int x,int y)

{

int fx=find(x);

int fy=find(y);

f[fx]=fy;

}

int same(int x,int y)

{

if(find(x)==find(y))

return 1;

return 0;

}

int main()

{

// freopen("C:\\1.txt","r",stdin);

int N,d;

cin>>N>>d;

int i;

for(i=1;i<=N;i++)

{

cin>>a[i].x>>a[i].y;

f[i]=i;

}

string str;

while(cin>>str)

{

if(str[0]=='O')

{

int t;

cin>>t;

in[t]=1;

for(i=1;i<=N;i++)

if(i!=t&&in[i]&&dis(a[i],a[t])<=d)

Union(i,t);

}

else

{

int t1,t2;

cin>>t1>>t2;

if(same(t1,t2))

cout<<"SUCCESS"<<endl;

else

cout<<"FAIL"<<endl;

}

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: