您的位置:首页 > 其它

POJ_3254_Corn Fields

2015-08-09 12:28 399 查看
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 9881Accepted: 5226
Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares
are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice
as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways
he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N

Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input
2 3
1 1 1
0 1 0

Sample Output
9

Hint

Number the squares as follows:

1 2 3
4


There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

状态压缩dp,可以把每一行看成一个状态,用一个二进制来表示,但是不能开太大的数组,就可以把每一行代表的二进制数表示成十进制,由于每一行的状态只跟上一行有关,所以用一个二维数组表示d[i][j],i表示函数,j表示状态,dp[i][j]=sum(f[i-1,k])(k表示上一行的状态,可以用枚举);

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;
int m,n;
int maxn=1<<12;
int field[13];

int mod=100000000;
int dp[13][1<<12];

bool judge1(int f,int p)
{
if(!((~f)&p)&&!(p&(p>>1))) return true;
else return false;
}

bool judge2(int pre,int pos)
{
if(!(pre&pos))return true;
else return false ;
}

int main()
{
#ifndef ONLINE_JUDGE
freopen("1.in","r",stdin);
freopen("out.txt","w",stdout);
#endif
while(scanf("%d%d",&m,&n)!=EOF)
{
memset(dp,0,sizeof(dp));
memset(field,0,sizeof(field));
int a;
for(int i=1;i<=m;i++)
{
for(int j=0;j<n;j++)
{
scanf("%d",&a);
if(a==1) field[i]+=(1<<j);
}
}
dp[0][0]=1;
for(int i=1;i<=m;i++)
{
for(int j=0;j<(1<<n);j++)
{
if(judge1(field[i],j))
{
for(int k=0;k<(1<<n);k++)
{
if(judge2(j,k))
{
dp[i][j]=(dp[i][j]+dp[i-1][k])%mod;
}
}

}//cout<<dp[i][j]<<" "<<i<<" "<<j<<endl;
}
}
int ans=0;
for(int i=0;i<(1<<n);i++) ans=(ans+dp[m][i])%mod;
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: