您的位置:首页 > 其它

BestCoder Round #50 (div.2) & HDOJ5366 The mook jong(dp)

2015-08-09 10:37 375 查看
Problem Description



ZJiaQ want to become a strong man, so he decided to play the mook jong。ZJiaQ want to put some mook jongs in his backyard. His backyard consist of n bricks that is 1*1,so it is 1*n。ZJiaQ want to put a mook jong in
a brick. because of the hands of the mook jong, the distance of two mook jongs should be equal or more than 2 bricks. Now ZJiaQ want to know how many ways can ZJiaQ put mook jongs legally(at least one mook jong).

Input

There ar multiply cases. For each case, there is a single integer n( 1 < = n < = 60)

Output

Print the ways in a single line for each case.

Sample Input

1	
2
3
4
5
6


Sample Output

1
2
3
5
8
12


简单的dp 一下就被田神秒了= = 注意long long

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 65;
int n;
long long dp[maxn];
int main()
{
    dp[1] = 1, dp[2] = 2, dp[3] = 3, dp[4] = 5;
    for(int i = 5; i <= 60; ++i)
        dp[i] = dp[i- 1] + dp[i - 3] + 1;
    while(scanf("%d", &n) != EOF)
        printf("%I64d\n", dp
);
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: