您的位置:首页 > 其它

田忌赛马 南阳oj364 HDU杭电1052【贪心】

2015-08-08 23:36 393 查看
描述
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from
the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you
think of Tian Ji, the high ranked official in China?"

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's
horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find
the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too
advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

输入The input consists of many test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s
horses. Then the next n integers on the third line are the speeds of the king’s horses.
输出For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

样例输入
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18


样例输出
200
0
0


#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int n;
	int a[1010],b[1010];//a是自己的马 
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;++i)
			scanf("%d",a+i);
		for(int i=0;i<n;++i)
			scanf("%d",b+i);
		sort(b,b+n);
		sort(a,a+n);
		int cnt=1;//记录比赛的次数 
		int i=0,j=0;
		int n1=n-1,n2=n-1;
		int sum=0;
		while(cnt++<=n)//比n场 
		{
			if(a[i]>b[j])
			{
				sum+=200;
				i++;
				j++;	
			}
			else if(a[i]<b[j])//反正也是输,和最强的那个打 
			{
				sum-=200;
				i++;
				n2--;
			}
			else //相等的时候 
			{
				if(a[n1]>b[n2])//判断头 
				{
					sum+=200;
					n1--;
					n2--;
				}
				else //当当前最强小于等于别人的,就把最弱的马和他比,因为这时自己最强还有可能赢,就更贪心 
				{
					if(a[i]<b[n2])//这里存在自己最大的和最小的都与对方最大的相同就不需要减200了 
					{
						sum-=200;
						i++;
						n2--;
					}
				}
				
			}	
		} 
		printf("%d\n",sum);
	}
	return 0;
}  
/*
8
11 9 8 8 8 4 3 2 
11 8 8 8 8 4 3 2 
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: