您的位置:首页 > 其它

usaco 1.2 Dual Palindromes 题解

2015-08-08 21:16 369 查看

题目描述

A number that reads the same from right to left as when read from left to right is called a palindrome. The number 12321 is a palindrome; the number 77778 is not. Of course, palindromes have neither leading nor trailing zeroes, so 0220 is not a palindrome.

The number 21 (base 10) is not palindrome in base 10, but the number 21 (base 10) is, in fact, a palindrome in base 2 (10101).

Write a program that reads two numbers (expressed in base 10):

N (1 <= N <= 15)

S (0 < S < 10000)

and then finds and prints (in base 10) the first N numbers strictly greater than S that are palindromic when written in two or more number bases (2 <= base <= 10).

Solutions to this problem do not require manipulating integers larger than the standard 32 bits.

PROGRAM NAME: dualpal

INPUT FORMAT

A single line with space separated integers N and S.

SAMPLE INPUT (file dualpal.in)

3 25

OUTPUT FORMAT

N lines, each with a base 10 number that is palindromic when expressed in at least two of the bases 2..10. The numbers should be listed in order from smallest to largest.

SAMPLE OUTPUT (file dualpal.out)

26

27

28

题目解析

回文数的概念在上一篇里有介绍,上边英文也有介绍,不详细说了。本题的要求是,输入两个数,N 和 S。找出比S大的N个数,这些数字的要求是在2~10的进制的情况下必须是回文数,而且要求是回文数的情况要 **大于等于2次** ,就是说必须满足回文的进制情况要至少为2次。。。当时写题的时候没看到,所以提交了好几次没有过,代码也没有检查出不过。

理解了题目做起来也就好做了。和上一篇有些类似,需要判断回文数,只是这次是将其作为了一个判断函数。代码如下:


/*
ID: ******
PROG: dualpal
LANG: C++
*/
#include <iostream>
#include <fstream>

using namespace std;

const char a[]="0123456789";

bool pal(int num)//判断回文数&&且判断回文数次数
{
int gaga=0;
for(int n=2;n<11;n++)
{
int kk=num;
string mystring="";
while(kk!=0)
{
mystring += a[kk%n];
kk/=n;
}
int len=mystring.length();
int flag1=0;
for(int i=0;i<len/2;i++)
{
if(mystring[i]!=mystring[len-1-i])
{
flag1++;
break;
}
}
if(flag1==0)
{
gaga++;
if(gaga==2)
return true;
}
}
return false;
}

int main()
{
ifstream fin("dualpal.in");
ofstream fout("dualpal.out");

int n,s;
//cin>>n>>s;
fin>>n>>s;
int flag=0;
int num=s;
while(flag<n)
{
num++;
if(pal(num))
{
flag++;
fout<<num<<endl;
//cout<<num<<endl;
}
}
//cout << "Hello world!" << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: