您的位置:首页 > 其它

Count the string

2015-08-08 19:03 211 查看


Count the string


Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)


Total Submission(s) : 22 Accepted Submission(s) : 11


Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example: s: "abab" The prefixes are: "a", "ab", "aba", "abab" For each prefix,
we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 +
2 + 1 + 1 = 6. The answer may be very large, so output the answer mod 10007.

Input

The first line is a single integer T, indicating the number of test cases. For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case
letters.

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1

4

abab

Sample Output

6

Author

foreverlin@HNU

Source

HDOJ Monthly Contest – 2010.03.06

原网址:http://www.cnblogs.com/jackge/archive/2013/04/20/3032942.html

如果用dt[i]表示该字符串前i个字符中出现任意以第i个字符结尾的前缀的次数,它的递推式是 dt[i]=d[next[i]]+1

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int mod=10007;

int a[200010],dp[200010];
char str[200010];

void getnext(int len){
int i=0,j=-1;
a[0]=-1;
while(i<len){
if(j==-1 || str[i]==str[j]){
i++;j++;
a[i]=j;
}else
j=a[j];
}
}

int main(){

//freopen("input.txt","r",stdin);

int t,n;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
scanf("%s",str);
getnext(n);
memset(dp,0,sizeof(dp));
int sum=0;
for(int i=1;i<=n;i++){
dp[i]=(dp[a[i]]+1);
sum=(sum+dp[i])%mod;
}
printf("%d\n",sum);
}
return 0;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: