您的位置:首页 > 其它

Desert King (poj 2728 最优比率生成树 0-1分数规划)

2015-08-08 14:47 495 查看
Language:
Default

Desert King

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 22113Accepted: 6187
Description

David the Great has just become the king of a desert country. To win the respect of his people, he decided to build channels all over his country to bring water to every village. Villages which are connected to his capital village will be watered. As the dominate
ruler and the symbol of wisdom in the country, he needs to build the channels in a most elegant way.

After days of study, he finally figured his plan out. He wanted the average cost of each mile of the channels to be minimized. In other words, the ratio of the overall cost of the channels to the total length must be minimized. He just needs to build the necessary
channels to bring water to all the villages, which means there will be only one way to connect each village to the capital.

His engineers surveyed the country and recorded the position and altitude of each village. All the channels must go straight between two villages and be built horizontally. Since every two villages are at different altitudes, they concluded that each channel
between two villages needed a vertical water lifter, which can lift water up or let water flow down. The length of the channel is the horizontal distance between the two villages. The cost of the channel is the height of the lifter. You should notice that
each village is at a different altitude, and different channels can't share a lifter. Channels can intersect safely and no three villages are on the same line.

As King David's prime scientist and programmer, you are asked to find out the best solution to build the channels.
Input

There are several test cases. Each test case starts with a line containing a number N (2 <= N <= 1000), which is the number of villages. Each of the following N lines contains three integers, x, y and z (0 <= x, y < 10000, 0 <= z < 10000000). (x, y) is the
position of the village and z is the altitude. The first village is the capital. A test case with N = 0 ends the input, and should not be processed.
Output

For each test case, output one line containing a decimal number, which is the minimum ratio of overall cost of the channels to the total length. This number should be rounded three digits after the decimal point.
Sample Input
4
0 0 0
0 1 1
1 1 2
1 0 3
0

Sample Output
1.000

Source

Beijing 2005
题意:将n个村庄连在一起,告诉每个村庄的三维坐标,村庄之间的距离为水平方向上的距离,花费为垂直方向上的高度差,求把村庄连接起来的最小的花费与长度之比为多少。

思路:经典的01分数规划问题,参考这位大神的讲解应该就能明白了:http://www.cnblogs.com/Fatedayt/archive/2012/03/05/2380888.html

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FREE(i,a,b) for(i = a; i >= b; i--)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define FRLL(i,a,b) for(i = a; i > b; i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define DBG         pf("Hi\n")
typedef long long ll;
using namespace std;

#define INF 0x3f3f3f3f
#define mod 1000000009
const int maxn = 1005;
const int MAXN = 2005;
const int MAXM = 200010;
const int N = 1005;

double x[maxn],y[maxn],z[maxn];
double dist[maxn],mp[maxn][maxn],len[maxn][maxn],cost[maxn][maxn];
bool vis[maxn];
int pre[maxn];
int n;

double Dis(int i,int j)
{
    return sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
}

double prim(double r)
{
    int i,j,now;
    double mi,c=0,l=0;
    for (i=0;i<n;i++)
    {
        dist[i]=INF;
        for (j=0;j<n;j++)
        {
            mp[i][j]=cost[i][j]-r*len[i][j];
        }
    }
    for (i=0;i<n;i++)
    {
        dist[i]=mp[i][0];
        pre[i]=0;
        vis[i]=false;
    }
    dist[0]=0;
    vis[0]=true;
    for (i=1;i<n;i++)
    {
        mi=INF;now=-1;
        for (j=0;j<n;j++)
        {
            if (!vis[j]&&mi>dist[j])
            {
                mi=dist[j];
                now=j;
            }
        }
        if (now==-1) break;
        vis[now]=true;
        c+=cost[pre[now]][now];
        l+=len[pre[now]][now];
        for (j=0;j<n;j++)
        {
            if (!vis[j]&&dist[j]>mp[now][j])
            {
                dist[j]=mp[now][j];
                pre[j]=now;
            }
        }
    }
    return c/l;
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("C:/Users/lyf/Desktop/IN.txt","r",stdin);
#endif
    int i,j;
    while (sf(n))
    {
        if (n==0) break;
        for (i=0;i<n;i++)
            scanf("%lf%lf%lf",&x[i],&y[i],&z[i]);
        for (i=0;i<n;i++)
        {
            for (j=0;j<n;j++)
            {
                len[i][j]=Dis(i,j);
                cost[i][j]=fabs(z[i]-z[j]);
            }
        }
        double r=0,rate;    //r迭代初值为0
        while (1)
        {
            rate=r;
            r=prim(r);
            if (fabs(r-rate)<eps) break;
        }
        printf("%.3f\n",r);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: