您的位置:首页 > 其它

The Blocks Problem

2015-08-08 10:35 393 查看
The Blocks Problem

Description



Background 

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.
In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of commands.

The Problem 

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are
n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block
bi+1 for all

as shown in the diagram below:
 

Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

move a onto b
where a and b are block numbers, puts block a onto block
b after returning any blocks that are stacked on top of blocks a and
b to their initial positions.

move a over b
where a and b are block numbers, puts block a onto the top of the stack containing block
b, after returning any blocks that are stacked on top of block a to their initial positions.

pile a onto b
where a and b are block numbers, moves the pile of blocks consisting of block
a, and any blocks that are stacked above block a, onto block
b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block
a retain their order when moved.

pile a over b
where a and b are block numbers, puts the pile of blocks consisting of block
a, and any blocks that are stacked above block a, onto the top of the stack containing block
b. The blocks stacked above block a retain their original order when moved.

quit
terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

The Input 

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 <
n < 25.
The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the
quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output 

The output should consist of the final state of the blocks world. Each original block position numbered
i (

where
n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated
from other block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where
n is the integer on the first line of input).

Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output 

0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:


大意:
给出n个积木,编号为0到n-1,放在位置为0到n-1上;

游戏规则如下:(以下a,b均为积木的编号)

move a onto b:将a,b之上的积木放回原位置,再将a放到b上;

move a over b:将a之上的积木放回原位置,再将a放到b所在的积木堆之上;

pile a onto b:将b之上的积木放回原位置,再将a本身和它之上的积木放到b之上;

pile a over b:将a本身和它之上的积木放到b所在的积木堆之上;

quit:结束游戏;

规则3和规则4放置积木时应和它先前的顺序一致,sample input的动作6;

如果a和b的编号一致或者a,b所在的积木堆吸相同则该动作忽略;

要点:

模拟即可;

代码:

#include <cstdio>
#include <cstring>

int main(){
int number[25], pile[25][25];
int num;
while (scanf("%d", &num) != EOF){
getchar();
for (int i = 0; i < num; i++){
pile[i][0] = i;
number[i] = 1;
}
char ask1[5], ask2[5];
int n1, n2, li1, li2, lj1, lj2;
while (scanf ("%s", ask1) && strcmp(ask1, "quit")){
getchar();
scanf ("%d%s%d", &n1, ask2, &n2);
for (int i = 0; i < num; i++){
for (int j = 0; j < number[i]; j++) {
if (pile[i][j] == n1)
li1 = i, lj1 = j;
if (pile[i][j] == n2)
li2 = i, lj2 = j;
}
}
if (n1 == n2 || li1 == li2)
continue;
if (!strcmp(ask1, "move")){
if (!strcmp(ask2, "onto")){
for (int j = lj1 + 1; j < number[li1]; j++){
pile[pile[li1][j]][number[pile[li1][j]]++] = pile[li1][j];
}
number[li1] = lj1 + 1;
for (int j = lj2 + 1; j < number[li2]; j++) {
pile[pile[li2][j]][number[pile[li2][j]]++] = pile[li2][j];
}
number[li2] = lj2 + 1;

pile[li2][number[li2]] = pile[li1][lj1];
number[li2]++, number[li1]--;
}
else {
for (int j = lj1 + 1; j < number[li1]; j++){
pile[pile[li1][j]][number[pile[li1][j]]++] = pile[li1][j];
}
number[li1] = lj1 + 1;

pile[li2][number[li2]] = pile[li1][lj1];
number[li2]++, number[li1]--;
}
}
else{
if (!strcmp(ask2, "onto")){
for (int j = lj2 + 1; j < number[li2]; j++) {
pile[pile[li2][j]][number[pile[li2][j]]++] = pile[li2][j];
}
number[li2] = lj2 + 1;

for (int j = lj1; j < number[li1]; j++){
pile[li2][number[li2]++] = pile[li1][j];
}
number[li1] = lj1;
}
else{
for (int j = lj1; j < number[li1]; j++){
pile[li2][number[li2]++] = pile[li1][j];
}
number[li1] = lj1;
}
}
}
for (int i = 0; i < num; i++){
printf ("%d:", i);
if (num
4000
ber[i] > 0)
for (int j = 0; j < number[i]; j++)
printf (" %d", pile[i][j]);
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: