您的位置:首页 > 其它

HDU - 1540 Tunnel Warfare 线段树 或者 让人心酸的暴力过

2015-08-07 22:18 501 查看
HDU - 1540

Tunnel Warfare

Time Limit: 2000MSMemory Limit: 32768KB64bit IO Format: %I64d & %I64u
Submit Status

Description

During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village
was directly connected with two neighboring ones.

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration
of connection must be done immediately!

Input

The first line of the input contains two positive integers n and m (n, m ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event.

There are three different events described in different format shown below:

D x: The x-th village was destroyed.

Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself.

R: The village destroyed last was rebuilt.

Output

Output the answer to each of the Army commanders’ request in order on a separate line.

Sample Input

7 9
D 3
D 6
D 5
Q 4
Q 5
R
Q 4
R
Q 4


Sample Output

1
0
2
4


暴力代码:
/*
Author: 2486
Memory: 1532 KB		Time: 374 MS
Language: G++		Result: Accepted
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <iterator>
using namespace std;
const int MAXN = 50000 + 5;
int N, M, x, top;
char op[10];
map<int,int>G;
int stack[MAXN];
int main() {
//freopen("D://imput.txt","r",stdin);
while(~ scanf("%d%d", &N, &M)) {
top = -1;
G.clear();
map<int,int>::iterator it;
for(int i = 0; i < M ; i ++) {
scanf("%s", op);
if(op[0] == 'D') {
scanf("%d", &x);
stack[++ top] = x;
G[x] = 1;
} else if(op[0] == 'R') {
int tmp = stack[top --];
G.erase(tmp);
} else {
scanf("%d", &x);
int l = 0, h = N;
for(it = G.begin(); it != G.end(); it ++) {
if(it -> first <= x) {
l = it -> first;
}
if(it -> first >= x) {
h = it -> first;
break;
}
}
if(h == l) {
printf("0\n");
} else if(h == N && l == 0) {
printf("%d\n", N);
} else if(h != N && l == 0) {
printf("%d\n", h - 1);
} else if(h == N && l != 0) {
printf("%d\n", N - l);
} else if(h != N && l != 0) {
printf("%d\n", h - l - 1);
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: