您的位置:首页 > 其它

hdoj 2717 Catch That Cow(一维坐标广搜)

2015-08-07 22:12 447 查看




本题最大的障碍就是如何记录最优路线的步数!


Catch That Cow


Time Limit : 4000/2000ms (Java/Other) Memory Limit : 131072/65536K (Java/Other)


Total Submission(s) : 124 Accepted Submission(s) : 48


Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number
line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?



Input

Line 1: Two space-separated integers: N and K



Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.



Sample Input

5 17




Sample Output

4




AC码
<span style="font-size:14px;">#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
#define max 100010
int step[max];
int vis[max];
queue<int>q;
int  bfs(int n,int m)
{

	int head,next;
	step
=0;
	vis
=1;
	q.push(n);
 while( !q.empty())   
    {
        head=q.front();
        q.pop();
        for(int i=0;i<3;i++)
        {
            if(i==0) next=head-1;
            else if(i==1) next=head+1;
            else next=head*2;
            if(next>max || next<0) continue;
            if(!vis[next]) 
            {
                vis[next]=1;  //当两次都走到相同位置时,当然要取步数少的,所以后到的就不用再往下走了 
                q.push(next);
                step[next]=step[head]+1; //此种存储方式才是本题的核心 
            }
            if(m==next) 
			return step[next]; //广搜搜索的深度第一次相等的就是深度最小的那个支结点,所以没必要再比较哪个最少了

        }
    
    }
}	
int main()
{	

	int m,n,i,j;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		memset(vis,0,sizeof(vis)); 
		printf("%d\n",bfs(m,n));
	}
	return 0;
}</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: