您的位置:首页 > 其它

UVA 10020 - Minimal coverage 解题心得

2015-08-07 19:55 891 查看
原题:

The Problem

Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].

The Input

The first line is the number of test cases, followed by a blank line.

Each test case in the input should contains an integer M(1<=M<=5000), followed by pairs "Li Ri"(|Li|, |Ri|<=50000, i<=100000), each on a separate line. Each test case of input is terminated by pair "0 0".

Each test case will be separated by a single line.

The Output

For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair "0 0" should not be printed. If [0,M] can not be covered by given line segments, your programm should print "0"(without quotes).

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

1
-1 0
-5 -3
2 5
0 0

1
-1 0
0 1
0 0


Sample Output

0

1
0 1

分析:经典的贪心题,记得贪心一点就能做对了~

代码:


#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

struct interval
{
int x, y;

}itvl[100006], max_end[100006];

bool cmp(const interval &a, const interval &b)
{
return a.x < b.x;
}

int main()
{
int kase;
cin >> kase;
getchar();
while (kase--){
int ok = 0;
int m,n=0;
int cnt = 0;
cin >> m;
while (scanf("%d%d", &itvl
.x, &itvl
.y) && (itvl
.x != 0 || itvl
.y != 0)){
++n;
}
sort(itvl, itvl + n,cmp);

int beg = 0, end = m;
while (beg < end){
max_end[cnt].y = 0;
for (int i = 0; i < n; i++){
if (itvl[i].x <= beg){
if (itvl[i].y>max_end[cnt].y)    {
max_end[cnt] = itvl[i];
ok = 1;
}
}
else{
break;
}
}
if (ok == 0)        break;
beg = max_end[cnt].y;
cnt++;
}

//                        输出

if (ok == 1){
cout << cnt << endl;
for (int i = 0; i < cnt; i++){
cout << max_end[i].x << ' ' << max_end[i].y << endl;
}
}
else{
cout <<'0'<< endl;
}
if (kase != 0)            cout << endl;

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: