您的位置:首页 > 其它

HDOJ Cyclic Nacklace 3746【KMP】

2015-08-07 18:37 309 查看

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4063 Accepted Submission(s): 1830



Problem Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial
spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful
decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with
colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost
pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:



Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that
is to say, adding to the middle is forbidden.

CC is satisfied with his ideas and ask you for help.


Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.

Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000
).


Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.


Sample Input

3
aaa
abca
abcde




Sample Output

0
2
5




Author

possessor WC


Source

HDU 3rd “Vegetable-Birds
Cup” Programming Open Contest


Recommend

lcy | We have carefully selected several similar problems for you: 1358 2222 3068 2896 3744
题意:给你一个字符串 头尾可以连接(这句没什么乱用) 问你最少添加几个字符,会组成至少两个循环的字符串

比如abca 在最后加bc 就是一个两个循环的字符串

解题思路:

这题主要考察KMP中next数组的使用~next数组就是用来存最长公共前缀的,所以我们只要求出了最长公共前缀L 用串的长度l%L就得到剩下的 然后用L 再减去剩下的 就得到最少要加的珠子。

AC代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 100000+10

using namespace std;

char P[maxn];
int pre[maxn];

void getnext(int n)
{
	int i=0,j=-1;
	pre[0]=-1;
	while(i<n){
		if(j==-1||P[i]==P[j]){
			pre[++i]=++j;
		}
		else j=pre[j];
	}
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--){
		scanf("%s",P);
		int l=strlen(P);
		getnext(l);
		int L=l-pre[l];//循环节长度
		if(l%L==0&&L!=l){
			printf("0\n");
			continue;
		}
		int res=L-l%L; 
		printf("%d\n",res);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: