您的位置:首页 > 其它

POJ 2752 Seek the Name, Seek the Fame(KMP next数组运用)

2015-08-07 17:34 274 查看
Seek the Name, Seek the Fame

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14128 Accepted: 7031
Description
The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape
from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings
of S? (He might thank you by giving your baby a name:)

Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.
Sample Input
ababcababababcabab
aaaaa

Sample Output
2 4 9 18
1 2 3 4 5

学会了next数组的另一种用法
ac代码:
 
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define MAXN 400010
using namespace std;
int len;
char s[MAXN];
int next[MAXN];
int a[MAXN];
void make()
{
int i=0;
int j=-1;
next[i]=j;
while(i<len)
{
if(j==-1||s[i]==s[j])
{
i++;
j++;
next[i]=j;
}
else
j=next[j];
}
}
int main()
{
int i,k,j,n;
while(scanf("%s",s)!=EOF)
{
len=strlen(s);
make();
i=len;
n=0;
while(next[i]!=-1)
{
a[n++]=i;
i=next[i];
}
for(i=n-1;i>0;i--)
printf("%d ",a[i]);
printf("%d\n",len);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: