您的位置:首页 > 其它

PKU 2406:Power Strings 【KMP】

2015-08-07 16:47 351 查看

Power Strings

Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 70   Accepted Submission(s) : 27
[align=left]Problem Description[/align]
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in
the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
 

[align=left]Input[/align]
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
 

[align=left]Output[/align]
For each s you should print the largest n such that s = a^n for some string a.

 

[align=left]Sample Input[/align]

abcd
aaaa
ababab
.

 

[align=left]Sample Output[/align]

1
4
3

 
题意:给一个字符串S长度不超过10^6,求最大的n使得S由n个相同的字符串a连接而成,如:"ababab"则由n=3个"ab"连接而成,"aaaa"由n=4个"a"连接而成,"abcd"则由n=1个"abcd"连接而成。

定理:假设S的长度为len,则S存在循环子串,当且仅当,len可以被len - next[len]整除,最短循环子串为S[len - next[len]]

例子证明:

设S=q1q2q3q4q5q6q7q8,并设next[8] = 6,此时str = S[len - next[len]] = q1q2,由字符串特征向量next的定义可知,q1q2q3q4q5q6
= q3q4q5q6q7q8,即有q1q2=q3q4,q3q4=q5q6,q5q6=q7q8,即q1q2为循环子串,且易知为最短循环子串。由以上过程可知,若len可以被len
- next[len]整除,则S存在循环子串,否则不存在。

解法:利用KMP算法,求字符串的特征向量next,若len可以被len - next[len]整除,则最大循环次数n为len/(len - next[len]),否则为1。

这个是我在一篇博客上看到的。。。不懂为什么。。。。如果有大神知道。。。望不吝赐教!!!

AC-code:

#include<cstdio>
#include<cstring>
const int N=1001000;
char str
;
int p
,len;
void getp()
{
int i=0,j=-1;
p[i]=j;
while(i<len)
{
if(j==-1||str[i]==str[j])
{
i++,j++;
if(str[i]==str[j])
p[i]=p[j];
else
p[i]=j;
}
else
j=p[j];
}
}
int main()
{
while(scanf("%s",str))
{
if(!strcmp(str,"."))
break;
len=strlen(str);
getp();
if(len%(len-p[len])==0)
printf("%d\n",len/(len-p[len]));
else
printf("1\n");
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: