您的位置:首页 > 其它

poj2406 power strings 【KMP】

2015-08-07 16:13 423 查看

Power Strings

Time Limit : 6000/3000ms (Java/Other) Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 66 Accepted Submission(s) : 25
Problem Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in
the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).


Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.


Output
For each s you should print the largest n such that s = a^n for some string a.



Sample Input
abcd
aaaa
ababab
.




Sample Output
1
4
3




【分析】如果len可以被len-next[len]整除,则s存在循环子串,否则不存在。最短循环子串为str[len-next[len]],最大循环次数为len/(len-next[len]).
【代码】

#include<stdio.h>
#include<string.h>
const int maxn = 1000010;
int p[maxn],len;
char s[maxn];
void getp()
{
	int i=0,j=-1;
	p[i]=j;
	while(i<len)
	{
		if(j==-1||s[i]==s[j])
		{
			i++,j++;
			p[i]=j;
		}
	   	else j=p[j];
	}
}

int main()
{
	while(scanf("%s",s)&&strcmp(s,"."))
	{
		len=strlen(s);
		getp();
		if(len%(len-p[len])==0)
		   printf("%d\n",len/(len-p[len]));
		else
		   printf("1\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: