您的位置:首页 > 其它

POJ Power Strings 2406【KMP】

2015-08-07 12:06 369 查看
Power Strings

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 37379Accepted: 15443
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined
in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.

Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
Source
Waterloo local 2002.07.01


#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 1000000+10

using namespace std;

char P[maxn];
int pre[maxn];

void getnext(int plen)
{
	pre[0]=pre[1]=0;
	for(int i=1;i<plen;i++){
		int k=pre[i];
		while(k&&P[i]!=P[k])k=pre[k];
		pre[i+1]= P[k]==P[i]?k+1:0;
	}
}

int main()
{
	while(scanf("%s",P)!=EOF){
		if(P[0]=='.')break;
		int plen=strlen(P);
		getnext(plen);
		if(plen%(plen-pre[plen])==0)
			printf("%d\n",plen/(plen-pre[plen]));
		else printf("1\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: