您的位置:首页 > 其它

HDU 5363 Key Set(快速幂)

2015-08-06 21:29 429 查看


Key Set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Problem Description

soda has a set S with n integers {1,2,…,n}.
A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are
key set.

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤105),
indicating the number of test cases. For each test case:

The first line contains an integer n (1≤n≤109),
the number of integers in the set.

 

Output

For each test case, output the number of key sets modulo 1000000007.

 

Sample Input

4
1
2
3
4

 

Sample Output

0
1
3
7

 

Source

2015 Multi-University Training Contest 6

 
/*********************************************************************/

题意:给你一个具有n个元素的集合S{1,2,…,n},问集合S的非空子集中元素和为偶数的非空子集有多少个。

放入出题人的解题报告



解题思路:因为集合S中的元素是从1开始的连续的自然数,所以所有元素中奇数个数与偶数个数相同,或比偶数多一个。另外我们要知道偶数+偶数=偶数,奇数+奇数=偶数,假设现在有a个偶数,b个奇数,则



根据二项式展开公式



以及二项式展开式中奇数项系数之和等于偶数项系数之和的定理

可以得到上式





最后的结果还需减去



即空集的情况,因为题目要求非空子集

所以最终结果为



由于n很大,所以计算n次方的时候需要用到快速幂,不然会TLE

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<cmath>
#include<string>
#include<algorithm>
#include<iostream>
#define exp 1e-10
#define ll __int64
using namespace std;
const int N = 50;
const int inf = 1000000000;
const int mod = 1000000007;
void Quick_Mod(ll a, ll b, ll mod)
{
ll res = 1,term = a % mod;
while(b)
{
if(b & 1) res = (res * term) % mod;
term = (term * term) % mod;
b >>= 1;
}
printf("%I64d\n",res-1);
}
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
Quick_Mod(2,n-1,mod);
}
return 0;
}菜鸟成长记
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: