您的位置:首页 > 其它

Poj 1611 The Suspects

2015-08-06 10:57 267 查看
The Suspects

Time Limit: 1000MSMemory Limit: 20000K
Total Submissions: 27102Accepted: 13230
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects
from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500.
Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing
the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1


#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#define inf 0x3f3f3f3f
using namespace std;
int init[30001];
int lo(int r)
{
   return r==init[r]?r:init[r]=lo(init[r]);
}
void  fi(int a,int b)
{
    int p=lo(a);
    int q=lo(b);
    if(q>p)//注意是0号传染者传给别人,所以用小的赋值
        init[q]=p;
    else
        init[p]=q;
}
int main()
{
    int n,m,k,x,y;
    ios::sync_with_stdio(false);
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
        break;
        for(int i=0;i<n;i++)
        {
            init[i]=i;
        }
        int s=0;
        while(m--)
        {
            cin>>k;
            cin>>x;
            for(int j=1;j<k;j++)//虽然 题目给的输入形式特殊,但想方法,弄成普通并查集两两查找的形式,无论怎么处理都是最终把一组合成一个根上,所以这么处理简单
            {
                cin>>y;
                fi(x,y);
            }
        }
        int ans=0;
        for(int i=0;i<n;i++)
        {
            if(lo(i)==0 )//注意如果用if(init[i]==0)ans++,WA的话,就换成if(lo(i)==0)
            ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: