您的位置:首页 > 其它

Hdu 5349 MZL's simple problem 2015ACM多校对抗赛第五场

2015-08-06 10:05 429 查看


传送门: http://acm.hdu.edu.cn/showproblem.php?pid=5349


MZL's simple problem

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 908    Accepted Submission(s): 432


Problem Description

A simple problem

Problem Description

You have a multiple set,and now there are three kinds of operations:

1 x : add number x to set

2 : delete the minimum number (if the set is empty now,then ignore it)

3 : query the maximum number (if the set is empty now,the answer is 0)

 

Input

The first line contains a number N (N≤106),representing
the number of operations.

Next N line
,each line contains one or two numbers,describe one operation.

The number in this set is not greater than 109.

 

Output

For each operation 3,output a line representing the answer.

 

Sample Input

6
1 2
1 3
3
1 3
1 4
3

 

Sample Output

3
4

 

Source

2015 Multi-University Training Contest 5

 

set搞一下就好了

#include<iostream>
#include<cstdio>
#include<set>
using namespace std;
int main(){
int n;
while(~scanf("%d",&n)){
set<int> st;
set<int>::iterator it;
while(n--){
int op;scanf("%d",&op);
int val;
if(op==1){
scanf("%d",&val);
st.insert(val);
}else if(op==2){
if(st.size()){
it = st.begin();
st.erase(*it);
}
}else if(op==3){
if(st.size()==0)puts("0");
else{
it=st.end();
it--;
printf("%d\n",*it);
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  2015 acm hdu 多校 set