您的位置:首页 > 其它

南邮 OJ 1492 Nasty Hacks

2015-08-06 08:33 316 查看


Nasty Hacks

时间限制(普通/Java) : 1000 MS/ 3000 MS 运行内存限制 : 65536 KByte

总提交 : 23 测试通过 : 21

比赛描述

You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use

to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with
and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.

输入

The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The
first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤
r, e ≤ 106 and 0 ≤ c ≤ 106.

输出

Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or
not, or whether it does not make any difference.

样例输入

3

0 100 70

100 130 30

-100 -70 40

样例输出

advertise

does not matter

do not advertise

题目来源

Nordic 2006

#include<stdio.h>
int main(){
int n,r,e,c;
while(scanf("%d",&n)==1){
while(n--){
scanf("%d%d%d",&r,&e,&c);
e -= c;
if(r>e){
printf("do not advertise\n");
}else if(r<e){
printf("advertise\n");
}else{
printf("does not matter\n");
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: