您的位置:首页 > 其它

zoj 2100 Seeding

2015-08-05 23:55 316 查看
Seeding

Time Limit: 2 Seconds
Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.
Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive
it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?

Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.

Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.

Sample Input

4 4

.S..

.S..

....

....

4 4

....

...S

....

...S

0 0



Sample Output


YES

NO

恩,题目大意就是说让求给一个map,然后.是可以走的S是不可以走的,问能否不走回头路的情况下把.走完。深搜,要回溯

#include<cstdio>
#include<cstring>
int vis[10][10];
char map[10][10];
int n,m,flag,num,cnt;
int dir[4][2]={1,0,-1,0,0,-1,0,1};
void dfs(int x,int y,int num)
{
int nx,ny;
if(num==0)
{
flag=1;
return;
}
for(int i=0;i<4;++i)
{
nx=x+dir[i][0];
ny=y+dir[i][1];
if(!vis[nx][ny]&&nx>=0&&nx<n&&ny>=0&&ny<m&&map[nx][ny]=='.')
{
num--;
vis[nx][ny]=1;
dfs(nx,ny,num);
num++;
vis[nx][ny]=0;
}
}
}
int main()
{
while(scanf("%d%d",&n,&m)&&(n||m))
{
cnt=num=flag=0;
memset(map,0,sizeof(map));
memset(vis,0,sizeof(vis));
for(int i=0;i<n;++i)
{
getchar();
for(int j=0;j<m;++j)
{
scanf("%c",&map[i][j]);
if(map[i][j]=='.')num++;
}
}
if(map[0][0]=='S')
{
printf("NO\n");
continue;
}
vis[0][0]=1;
num--;
dfs(0,0,num);
//	printf("%d %d\n",num,cnt);
if(flag)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: