您的位置:首页 > 其它

poj1426(深搜)

2015-08-05 20:26 316 查看
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0


Sample Output

10
100100100100100100
111111111111111111


题目大意是让你找出一个只含0和1的数使之为输入的数的倍数。这种代码好懂自己写却不好写的深搜题还得多做多做啊!!5555555555

(题目说最多100位,实质上这题用无符号长整是可以做到的)

#include <iostream>
#include<memory.h>
#include<stdio.h>
using namespace std;
typedef unsigned __int64 ll;
ll t;bool flag;
void dfs(ll t,int n,int w)
{
if(flag==1)return;
if(t%n==0)
{
cout<<t<<endl;
flag=1;
return ;
}
if(w==19)return ;
dfs(t*10,n,w+1);
dfs(t*10+1,n,w+1);
}

int main()
{
int n;
while(cin>>n&&n!=0)
{
flag=0;
dfs(1,n,0);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: