您的位置:首页 > 其它

zoj 2100 Seeding

2015-08-05 20:16 459 查看

Seeding

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 138   Accepted Submission(s) : 69
[align=left]Problem Description[/align]
It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares. Tom has a seeding-machine. At the beginning, the machine lies
in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive
the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?

Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.

Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.

Sample Input

4 4

.S..

.S..

....

....

4 4

....

...S

....

...S

0 0



Sample Output


YES

NO

 

[align=left]Source[/align]
Zhejiang University Local Contest 2004

题目大概意思是在一个给定的矩形中,有一定数量的石头。我们要做的就是来判断是否能从左上角的位置出发,不碰石头,将其余的点走完(不能走回头路)。

这道题我的思路是判断走过的步数与石头的个数之和是否等于矩形元素数之和,若相等则输出结果,否则继续。
# include<stdio.h>
# include<string.h>
# include<algorithm>
using namespace std;
char a[10][10];
int n, m;
int cnt, s;
int k;
void dfs(int x, int y)
{
if(a[x][y] == 'S') //判断结束
return ;
if(x < 1 || y < 1 || x > m || y > n) //判断越界
return ;
cnt++;
if(cnt  == n * m)//判断结束
{
k = 1;
return ;
}
a[x][y] = 'S'; //将走过的位置变为石头 (即不能走回头路)
dfs(x+1,y);//朝四个方向搜索
dfs(x-1,y);
dfs(x,y+1);
dfs(x,y-1);
cnt--;        //这两行是这道题的精华之处 这两句不好理解 可以将它看作为如果前面是死路一条的话 就要回溯 从上一个位置继续走 但是由于上一步经过时加上了步数 并且标记了(将它的所在处变为了石头) 那么我们就要还原
a[x][y] = '.';

}
int main()
{
while(scanf("%d%d",&m,&n),m|n)
{	cnt=0;
int i, t;
for(i = 1; i <= m; i++)
{
getchar();
for(t = 1; t <= n; t++)
{
scanf("%c",&a[i][t]);
if(a[i][t] == 'S')//在输入中来判断石头的个数
cnt++;
}
}
k = 0;
dfs(1,1);
if(k == 1) printf("YES\n");
else printf("NO\n");
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: