您的位置:首页 > 产品设计 > UI/UE

【HDU1503】【Advanced Fruits】

2015-08-05 19:18 351 查看


Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1943 Accepted Submission(s): 994

Special Judge


Problem Description

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like
a mixture between both of them.

A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string
that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.



Input

Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.



Output

For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.



Sample Input

apple peach
ananas banana
pear peach




Sample Output

appleach
bananas
pearch




Source

University of Ulm Local Contest 1999



Recommend

linle

#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
string a,b;
int dp[110][110];
int p[110][110];
int l1,l2;
void dfs(int x,int y)
{
	if(x <= 0 && y <= 0) return ;
	if(p[x][y] == 1)
	{
		dfs(x-1,y-1);
		putchar(a[x]);
	}
	else if(p[x][y] == 2)
	{
		dfs(x,y-1);
		putchar(b[y]);
	}
	else if(p[x][y] == 3)
	{
		dfs(x-1,y);
		putchar(a[x]);
	}
	else
	{
		if(x >= 1)
		{
		  dfs(x-1,y);
		  putchar(a[x]);
		  return;
		}
		if(y >= 1)
		{
		  dfs(x,y-1);
		  putchar(b[y]);
		  return ;
		}
	}
}
int main()
{
    while(cin>>a && cin>>b)
	{
	  memset(dp,0,sizeof(dp));
	  memset(p,-1,sizeof(p));
	  a = " " + a;
	  b = " " + b;
	  l1 = a.length() - 1;
	  l2 = b.length() - 1;
	  for(int i=1;i<=l1;i++)
	  {
		  for(int j=1;j<=l2;j++)
		  {
			  if(a[i] == b[j])
			  {
				  dp[i][j] = dp[i-1][j-1] + 1;
				  p[i][j] = 1;
			  }
			  else 
			  {
				  if(dp[i][j-1] > dp[i-1][j])
				  {
					  dp[i][j] = dp[i][j-1];
					  p[i][j] = 2;
				  }
				  else if(dp[i][j-1] < dp[i-1][j])
				  {
					  dp[i][j] = dp[i-1][j];
					  p[i][j] = 3;
				  }
				  else
				  {
					dp[i][j] = dp[i-1][j];
					p[i][j] = 4;
				  }
			  }
		  }
	  }
	  dfs(l1,l2);
	  cout <<endl;
	}
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: