您的位置:首页 > 其它

Euclid's Game(poj2348+博弈)

2015-08-05 17:00 399 查看
B - Euclid's Game
Time Limit:1000MS Memory Limit:65536KB 64bit
IO Format:
%I64d & %I64u
Submit Status Practice POJ
2348


Appoint description:
System Crawler (2015-08-02)

Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then
Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with
(25,7):

25 7 
 11 7 
 4 7 
 4 3 
 1 3 
 1 0


an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0


Sample Output

Stan wins
Ollie wins




题目大意:

给两个数,两人依次取,规则是:每次从大的数那取(两数目相等时任选其一),取的数目只能为小的数的正整数倍。最后取完其中一个数的胜。问给定情况下先手胜负情况。

分析:

现有状态(x,y) (设x>0且y>0,其它情况自行考虑)

(1)当x==y时,显然先手胜

(2)不妨设x<y

那么(x+y,y)的下一步必定为(x,y),所以(x+y,y)和(x,y)的结果必然

相反,其中有一种状态可以先手胜,另一种后手胜

对于任意k>=2,状态(x+ky,y)可以通过从x+ky那堆去掉(k-1)y个石子

变成(x+y,y),也可以通过从x+ky那堆去掉ky个石子变成(x,y),

于是这两种选择(注意:这是自主的选择)必然有一种可以获胜,

所以当k>=2时(x+ky,y)必胜 注意这里的数据范围要用long long



转载请注明出处:寻找&星空の孩子



题目链接:http://poj.org/problem?id=2348



#include<stdio.h>
#include<algorithm>
#define LL long long
using namespace std;
LL cnt;
void fun(LL x,LL y)
{
    cnt++;
    if(x==y||x>=2*y)
        return ;
    else fun(y,x-y);
}
int main()
{
    LL n,m;
    while(scanf("%lld%lld",&n,&m),n+m)
    {
        cnt=0;
        if(n<m)swap(n,m);
        fun(n,m);
        if(cnt%2!=0) printf("Stan wins\n");
        else printf("Ollie wins\n");
    }
    return 0;
}




还有一种更加睿智的思路:

http://www.cnblogs.com/goodness/archive/2010/03/05/1678892.html
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: