您的位置:首页 > 大数据 > 人工智能

1023 Train Problem II(卡特兰数)

2015-08-05 16:49 225 查看
[align=left]Problem Description[/align]
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

[align=left]Input[/align]
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

[align=left]Output[/align]
For each test case, you should output how many ways that all the trains can get out of the railway.

[align=left]Sample Input[/align]

1
2
3
10

[align=left]Sample Output[/align]

1
2
5
16796

Hint

The result will be very large, so you may not process it by 32-bit integers.

[align=left]Author[/align]
Ignatius.L

卡特兰数相关了解:
http://blog.csdn.net/wuzhekai1985/article/details/6764858 http://www.cnblogs.com/kuangbin/archive/2012/03/21/2410519.html http://baike.baidu.com/link?url=SIrdv9w3YrmZdmGR5dIIszcQfzjndTjD9fHo1qzCYatFgsZIiwSbb2zOY70ouVcYZYES_1sbIXYuD1hbLaN78K
最初所写的代码(没考虑范围):

#include <stdio.h>
#include <algorithm>
int Catalan(int n){
if(n<=1)
return 1;
int *h = new int [n+100000];
h[0] = h[1] = 1;
for(int i=2;i<=n;i++){
h[i]=0;
for(int j=0;j<i;j++){
h[i]+=(h[j]*h[i-1-j]);
}
}
int result=h
;
delete []h;
return result;
}
int main()
{
int n;
while(~scanf("%d",&n)){
printf("%d\n",Catalan(n));
}
return 0;
}


bin神的模板:

#include <stdio.h>

//*******************************
//打表卡特兰数
//第 n个 卡特兰数存在a
中,a
[0]表示长度;
//注意数是倒着存的,个位是 a
[1] 输出时注意倒过来。
//*********************************
int a[105][100];
void ktl()
{
int i,j,yu,len;
a[2][0]=1;
a[2][1]=2;
a[1][0]=1;
a[1][1]=1;
len=1;
for(i=3;i<101;i++)
{
yu=0;
for(j=1;j<=len;j++)
{
int t=(a[i-1][j])*(4*i-2)+yu;
yu=t/10;
a[i][j]=t%10;
}
while(yu)
{
a[i][++len]=yu%10;
yu/=10;
}
for(j=len;j>=1;j--)
{
int t=a[i][j]+yu*10;
a[i][j]=t/(i+1);
yu = t%(i+1);
}
while(!a[i][len])
{
len--;
}
a[i][0]=len;
}

}
int main()
{
ktl();
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=a
[0];i>0;i--)
{
printf("%d",a
[i]);
}
puts("");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: