您的位置:首页 > 其它

poj 2318 TOYS(判点与线段的关系)

2015-08-05 16:37 501 查看
TOYS

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 11643Accepted: 5616
Description

Calculate the number of toys that land in each bin of a partitioned toy box.

Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the
toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example
toy box.




For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner
and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that
the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is
random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the
rightmost bin). Separate the output of different problems by a single blank line.
Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.
题意:给出矩形的左上和右下的坐标,在矩形中有n个木棒,木棒之间不会相交,然后给出木棒上下端点的横坐标,接着有m个玩具,给出玩具的坐标。输出木棒围成的区域中有玩具的个数。

题解:对于每个玩具二分找到对应的区域。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#define N 5050

using namespace std;

int n,m,x,y,x2,y2;

struct node {
    int x1,x2;
    int y1,y2;
} a
;
int ans
;

bool cmp(node a,node b) {
    if(a.x1==b.x1)return a.x2<b.x2;
    return a.x1<b.x1;
}

int okleft(int i,int x,int y) {///叉积判断(x,y)是否在线段a[i]的左边
    return (a[i].x1 - x) * (a[i].y2 - y) - (a[i].x2 - x) * (a[i].y1 - y);
}

//二分
int serch(int x,int y) {
    int l=0,r=n;
    int mid;
    while(l<r) {
        mid=(l+r)/2;
        if(okleft(mid,x,y)<0)
            r=mid;
        else
            l=mid+1;
    }
    return r;
}

int main() {
    //freopen("in.txt","r",stdin);
    while(~scanf("%d",&n)&&n) {
        scanf("%d%d%d%d%d",&m,&x,&y,&x2,&y2);
        for(int i=0; i<n; i++) {
            scanf("%d%d",&a[i].x1,&a[i].x2);
            a[i].y1=y;
            a[i].y2=y2;
        }
        sort(a,a+n,cmp);
        a
.x1=x2,a
.x2=x2;
        memset(ans,0,sizeof ans);
        int xm,ym;
        while(m--) {
            scanf("%d%d",&xm,&ym);
            int id=serch(xm,ym);
            ans[id]++;
        }
        for(int i=0; i<=n; i++)
            printf("%d: %d\n",i,ans[i]);
        printf("\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: