您的位置:首页 > 其它

POJ 1050 To the Max

2015-08-05 15:31 344 查看
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the
sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

is in the lower left corner:

9 2

-4 1

-1 8

and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines).
These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2


Sample Output

15


最大矩阵和

#include <stdio.h>

int main()
{
int n,i,j,k,sum,maxx,a[200][200],dp[200][200];
while(~scanf("%d",&n))
{
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
scanf("%d",&a[i][j]);
for(i=1;i<=n;i++)
{
dp[i][0]=0;
for(j=1;j<=n;j++)
{
dp[i][j]=dp[i][j-1]+a[i][j];
}
}

maxx=-999999;
for(i=1;i<=n;i++)
for(j=i;j<=n;j++)
{
sum=0;
for(k=1;k<=n;k++)
{
sum+=dp[k][j]-dp[k][i-1];
if(sum<0)
sum=0;
if(sum>maxx)
maxx=sum;
}
}

printf("%d\n",maxx);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: