您的位置:首页 > 其它

hdu 3038 How Many Answers Are Wrong (带权并查集)

2015-08-05 11:20 393 查看

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3883 Accepted Submission(s): 1482


[align=left]Problem Description[/align]
TT and FF are ... friends. Uh... very very good friends -________-b

FF
is a bad boy, he is always wooing TT to play the following game with
him. This is a very humdrum game. To begin with, TT should write down a
sequence of integers-_-!!(bored).



Then,
FF can choose a continuous subsequence from it(for example the
subsequence from the third to the fifth integer inclusively). After
that, FF will ask TT what the sum of the subsequence he chose is. The
next, TT will answer FF's question. Then, FF can redo this process. In
the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a
very very boring game!!! TT doesn't want to play with FF at all. To
punish FF, she often tells FF the wrong answers on purpose.

The
bad boy is not a fool man. FF detects some answers are incompatible. Of
course, these contradictions make it difficult to calculate the
sequence.

However, TT is a nice and lovely girl. She doesn't have
the heart to be hard on FF. To save time, she guarantees that the
answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But
there will be so many questions that poor FF can't make sure whether
the current answer is right or wrong in a moment. So he decides to write
a program to help him with this matter. The program will receive a
series of questions from FF together with the answers FF has received
from TT. The aim of this program is to find how many answers are wrong.
Only by ignoring the wrong answers can FF work out the entire sequence
of integers. Poor FF has no time to do this job. And now he is asking
for your help~(Why asking trouble for himself~~Bad boy)

[align=left]Input[/align]
Line
1: Two integers, N and M (1 <= N <= 200000, 1 <= M <=
40000). Means TT wrote N integers and FF asked her M questions.

Line
2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT
answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0
< Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

[align=left]Output[/align]
A single line with a integer denotes how many answers are wrong.

[align=left]Sample Input[/align]

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

[align=left]Sample Output[/align]

1

[align=left]Source[/align]
2009 Multi-University Training Contest 13 - Host by HIT



题意:第一行 一共n个数,m条信息; 接下来m行代表区间x到y的总和为w;

问:有多少条信息是错误的。

带权值的并查集,不是很理解,大概是用当前节点存与根节点的差值,然后再判是否冲突。

#include<iostream>
#include<vector>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <math.h>
#include<algorithm>
#define eps 1e-8
using namespace std;
const int N = 200050;
struct nodes
{
int r;
int oper;
} root
;

void init(int n)
{
int i;
for(i = 1; i <= n; i++)
root[i].r = i,root[i].oper = 0;
}
int find(int r)
{
if (r == root[r].r)
return r;
int temp = find(root[r].r);
root[r].oper += root[root[r].r].oper;//当递归到某一层时,r还未接到根节点上,就把权值累加上去

return root[r].r = temp;
}

int main(void)
{
int m,n,i,x,y,w,ans;
while(scanf("%d %d",&n,&m) != -1)
{
init(n);
ans = 0;
for(i = 0; i < m; i++)
{
scanf("%d %d %d",&x,&y,&w);
x--;//处理区间
int ra,rb;
ra = find(x);
rb = find(y);
if(ra != rb)
{
root[rb].r = ra;
root[rb].oper  = w + root[x].oper - root[y].oper; //rb节点与ra节点权值差
}
else
{
if(root[y].oper - root[x].oper != w) ans++;
}
}
printf("%d\n",ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: