您的位置:首页 > 大数据 > 人工智能

GCD Again HDU杭电1787

2015-08-05 11:07 387 查看
Problem Description

Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?

No? Oh, you must do this when you want to become a "Big Cattle".

Now you will find that this problem is so familiar:

The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little
more difficult problem:

Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.

This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.

Good Luck!



Input

Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.



Output

For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.



Sample Input

2
4
0




Sample Output

0
1




欧拉函数是指:对于一个正整数n,小于n且和n互质的正整数(包括1)的个数,记作φ(n) 。

通式:φ(x)=x*(1-1/p1)*(1-1/p2)*(1-1/p3)*(1-1/p4)…..(1-1/pn),其中p1, p2……pn为x的所有质因数,x是不为0的整数。φ(1)=1(唯一和1互质的数就是1本身)。

对于质数p,φ(p) = p - 1。注意φ(1)=1.

欧拉定理:对于互质的正整数a和n,有aφ(n) ≡ 1 mod n。

欧拉函数是积性函数——若m,n互质,φ(mn)=φ(m)φ(n)。

若n是质数p的k次幂,φ(n)=p^k-p^(k-1)=(p-1)p^(k-1),因为除了p的倍数外,其他数都跟n互质。

特殊性质:当n为奇数时,φ(2n)=φ(n)

欧拉函数还有这样的性质:

设a为N的质因数,若(N % a == 0 && (N / a) % a == 0) 则有E(N)=E(N / a) * a;若(N % a == 0 && (N / a) % a != 0) 则有:E(N) = E(N / a) * (a - 1)。


#include<stdio.h>    
int euler(int n)  
{      
	int ans=1;      
	int i;      
	for(i=2;i*i<=n;i++)      
	{          
		if(n%i==0)          
		{              
			n/=i;                                                                                                                     
			ans*=i-1;              
			while(n%i==0)              
			{                  
				n/=i;                  
				ans*=i;              
			}          
		}      
	}      
	if(n>1)          
	ans*=n-1;  //n已经为素数了    
	return ans;  
}  
int main()  
{      
	int n;      
	while(scanf("%d",&n),n)      
	{          
		printf("%d\n",n-1-euler(n));
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: