您的位置:首页 > 其它

最少步数

2015-08-04 21:19 363 查看

最少步数

时间限制:3000 ms  |  内存限制:65535 KB
难度:4

描述
这有一个迷宫,有0~8行和0~8列:

 1,1,1,1,1,1,1,1,1

 1,0,0,1,0,0,1,0,1

 1,0,0,1,1,0,0,0,1

 1,0,1,0,1,1,0,1,1

 1,0,0,0,0,1,0,0,1

 1,1,0,1,0,1,0,0,1

 1,1,0,1,0,1,0,0,1

 1,1,0,1,0,0,0,0,1

 1,1,1,1,1,1,1,1,1

0表示道路,1表示墙。

现在输入一个道路的坐标作为起点,再如输入一个道路的坐标作为终点,问最少走几步才能从起点到达终点?

(注:一步是指从一坐标点走到其上下左右相邻坐标点,如:从(3,1)到(4,1)。)

输入第一行输入一个整数n(0<n<=100),表示有n组测试数据;

随后n行,每行有四个整数a,b,c,d(0<=a,b,c,d<=8)分别表示起点的行、列,终点的行、列。输出输出最少走几步。样例输入
2
3 1  5 7
3 1  6 7

样例输出
12
11
C语言程序代码


#include<stdio.h>
#include<string.h>
#include<math.h>
#define N 0xfffffff
int a[9][9]={
1,1,1,1,1,1,1,1,1,
1,0,0,1,0,0,1,0,1,
1,0,0,1,1,0,0,0,1,
1,0,1,0,1,1,0,1,1,
1,0,0,0,0,1,0,0,1,
1,1,0,1,0,1,0,0,1,
1,1,0,1,0,1,0,0,1,
1,1,0,1,0,0,0,0,1,
1,1,1,1,1,1,1,1,1,
};
int min,x,y,ex,ey;
int dx[4]={0,1,-1,0};
int dy[4]={1,0,0,-1};
void dfs(int x,int y,int c)
{
 int i;
 if(x==ex&&y==ey)
 {
  if(c<min)
   min=c;
   return ;
 }
 for(i=0;i<4;i++)
 {
  int nx=x+dx[i];
  int ny=y+dy[i];
  if(a[nx][ny]==0&&c+1<min)
  {
   a[nx][ny]=1;
   dfs(nx,ny,c+1);
   a[nx][ny]=0;
  }
 }
}
int main(){
 int t;
 scanf("%d",&t);
 while(t--)
 {
  int c=0;
  scanf("%d%d%d%d",&x,&y,&ex,&ey);
  a[x][y]=1;
  min=N;
  dfs(x,y,c);
  a[x][y]=0;
  printf("%d\n",min);
 }
 return 0;
}


/*
BFS解
*/
#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
using namespace std;
#define INF 0xfffffff
int x,y,ex,ey,ans,vis[11][11];
int dx[4]={0,1,-1,0};
int dy[4]={1,0,0,-1};
int map[9][9]={
 1,1,1,1,1,1,1,1,1,
 1,0,0,1,0,0,1,0,1,
 1,0,0,1,1,0,0,0,1,
 1,0,1,0,1,1,0,1,1,
 1,0,0,0,0,1,0,0,1,
 1,1,0,1,0,1,0,0,1,
 1,1,0,1,0,1,0,0,1,
 1,1,0,1,0,0,0,0,1,
 1,1,1,1,1,1,1,1,1,
};
struct node
{
 int x,y,step;
}a,temp;
int jud(struct node a)
{
 if(a.x<0||a.x>=9)
  return 0;
 if(a.y<0||a.y>=9)
  return 0;
 if(vis[a.x][a.y]||map[a.x][a.y])
  return 0;
 if(temp.step>=ans)
  return 0;
 return 1;
}
void bfs()
{
 a.x=x;
 a.y=y;
 a.step=0;
 memset(vis,0,sizeof(vis));
 queue<node>q;
 vis[x][y]=1;
 q.push(a);
 while(!q.empty())
 {
  a=q.front();
  q.pop();
  for(int i=0;i<4;i++)
  {
   temp.x=a.x+dx[i];
   temp.y=a.y+dy[i];
   temp.step=a.step+1;
   if(jud(temp))
   {
    if(temp.x==ex&&temp.y==ey)
    {
     if(ans>temp.step)
      ans=temp.step;
     continue;
    }
    vis[temp.x][temp.y]=1;
    q.push(temp);
   }
  }
 }
}
int main()
{
 int t;
 scanf("%d",&t);
 while(t--)
 {
  int c=0;
  scanf("%d%d%d%d",&x,&y,&ex,&ey);
  if(x==ex&&y==ey)
  {
   printf("0\n");
   continue;
  }
  ans=INF;
  bfs();
  printf("%d\n",ans);
 }
 return 0;
}      
/*
BFS解;;优化
*/
#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
using namespace std;
#define INF 0xfffffff
int x,y,ex,ey,ans,vis[11][11];
int dx[4]={0,1,-1,0};
int dy[4]={1,0,0,-1};
int map[9][9]={
 1,1,1,1,1,1,1,1,1,
 1,0,0,1,0,0,1,0,1,
 1,0,0,1,1,0,0,0,1,
 1,0,1,0,1,1,0,1,1,
 1,0,0,0,0,1,0,0,1,
 1,1,0,1,0,1,0,0,1,
 1,1,0,1,0,1,0,0,1,
 1,1,0,1,0,0,0,0,1,
 1,1,1,1,1,1,1,1,1,
};
struct node
{
 int x,y,step;
 friend bool operator < (node a,node b)
 {
  return a.step>b.step;
 }
}a,temp;
int jud(struct node a)
{
 if(a.x<0||a.x>=9)
  return 0;
 if(a.y<0||a.y>=9)
  return 0;
 if(vis[a.x][a.y]||map[a.x][a.y])
  return 0;
 if(temp.step>=ans)
  return 0;
 return 1;
}
void bfs()
{
 a.x=x;
 a.y=y;
 a.step=0;
 memset(vis,0,sizeof(vis));
 priority_queue<node>q;
 vis[x][y]=1;
 q.push(a);
 while(!q.empty())
 {
  a=q.top();
  q.pop();
  for(int i=0;i<4;i++)
  {
   temp.x=a.x+dx[i];
   temp.y=a.y+dy[i];
   temp.step=a.step+1;
   if(jud(temp))
   {
    if(temp.x==ex&&temp.y==ey)
    {
    // if(ans>temp.step)
      ans=temp.step;
      return;
    // continue;
    }
    vis[temp.x][temp.y]=1;
    q.push(temp);
   }
  }
 }
}
int main()
{
 int t;
 scanf("%d",&t);
 while(t--)
 {
  int c=0;
  scanf("%d%d%d%d",&x,&y,&ex,&ey);
  if(x==ex&&y==ey)
  {
   printf("0\n");
   continue;
  }
  ans=INF;
  bfs();
  printf("%d\n",ans);
 }
 return 0;
}    
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: