您的位置:首页 > 其它

HDOJ 4707 Pet (并查集)

2015-08-04 21:02 393 查看

Pet

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 8   Accepted Submission(s) : 6
[align=left]Problem Description[/align]
One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for
three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere
nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is
always one distance unit.
 

[align=left]Input[/align]
The input contains multiple test cases. Thefirst line is a positive integer T (0
 

[align=left]Output[/align]
For each test case, outputin a single line the number of possible locations in the school the hamster may be found.
 

[align=left]Sample Input[/align]

1
10 2
0 1
0 2
0 3
1 4
1 5
2 6
3 7
4 8
6 9

 

[align=left]Sample Output[/align]

2

 

明明今天是DFS,但是这道题我用并查集竟然能过= = !

题意:

一只不知道是什么的宠物,然后要找他,总是从0点开始找,查找和0点相距D的点有几个,不会有环路

ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define MAXN 110000
using namespace std;
int pri[MAXN];
int sum,m;
int find(int x)
{
int r=x;
while(r!=pri[r])
r=pri[r];
return r;
}
int num(int a)
{
int b=0;
while(a!=pri[a])
{
a=pri[a];
b++;
}
return b;
}
void fun()
{
for(int i=MAXN;i>0;i--)
{
if(find(i)==0&&num(i)>m)//根节点为0且距离大于m
sum++;
}
}
int main()
{
int n,i,a,b,t;
scanf("%d",&t);
while(t--)
{
sum=0;
for(i=0;i<MAXN;i++)
pri[i]=i;
scanf("%d%d",&n,&m);
for(i=0;i<n-1;i++)
{
scanf("%d%d",&a,&b);
pri[b]=a;//直接并,不用查
}
fun();
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: