您的位置:首页 > 其它

poj-2553 Frogger

2015-08-04 19:57 381 查看
Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming
and instead reach her by jumping.

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates
of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three
decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

这个题题意是起点为第一块石头,终点为第二块,其余为垫脚石。然后找到从1到达2所需要的最大的跳远能力。实质上就是建立最小生成树,然后找到最小生成树的最长边,即它跳到2需要的最大跳跃能力。
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#define INF 0x3f3f3f3f

using namespace std;

struct node
{
int x,y;
}d[220];
double map[220][220];
double dis[220];
int vis[220];
int n;

void prim()
{
int i,j,pos;
double min,ans=0;
memset(vis,0,sizeof(vis));
for (i=1;i<=n;i++)
{
dis[i]=map[1][i];
}
vis[1]=1;
for (i=1;i<n;i++)
{
min=INF;
for (j=1;j<=n;j++)
{
if(min>dis[j]&&!vis[j])
min=dis[pos = j];
}
vis[pos]=1;
if(ans<dis[pos]) ans=dis[pos];
if(pos==2) break;
for (j=1;j<=n;j++)
{
if(!vis[j]&&dis[j]>map[pos][j])
{
dis[j]=map[pos][j];
}
}
}
printf("Frog Distance = %.3lf\n\n",ans);
}

int main()
{
int t=0,i,j;
while (~scanf("%d",&n),n)
{
memset(map,0,sizeof(map));
t++;
for (i=1;i<=n;i++)
{
scanf("%d%d",&d[i].x,&d[i].y);
}
for (i=1;i<n;i++)
{
for (j=i+1;j<=n;j++)
{
map[i][j]=sqrt((d[i].x-d[j].x)*(d[i].x-d[j].x)*1.0+(d[i].y-d[j].y)*(d[i].y-d[j].y));
map[j][i]=sqrt((d[i].x-d[j].x)*(d[i].x-d[j].x)*1.0+(d[i].y-d[j].y)*(d[i].y-d[j].y));
}
}
printf("Scenario #%d\n",t);
prim();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: